OpenWRT: Freefi.meshnet

Configuring a standard OpenWRT Compatible Router for use on Freefi.meshnet.

Wireless Configuration

root@OpenWrt:~# cat /etc/config/wireless 

config wifi-device 'radio0'
option type 'mac80211'
option macaddr 'XX:XX:XX:XX:XX:XX'
list ht_capab 'LDPC'
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option txpower '10'
option country 'GB'
option channel '1'
option hwmode '11g'

config wifi-iface
option device 'radio0'
option mode 'adhoc'
option ssid 'olsr.freefi.meshnet'
option encryption 'none'
option network 'mnet'

config 'wifi-device' 'radio1'
option 'type' 'mac80211'
option 'macaddr' 'XX:XX:XX:XX:XX:XX'
list 'ht_capab' 'GF'
list 'ht_capab' 'SHORT-GI-20'
list 'ht_capab' 'SHORT-GI-40'
list 'ht_capab' 'RX-STBC1'
option 'txpower' '14'
option 'hwmode' '11g'
option 'country' 'GB'
option 'channel' '6'

config 'wifi-iface'
option 'device' 'radio1'
option 'ssid' 'openwifi.notts.freefi.meshnet'
option 'mode' 'ap'
option 'network' 'lan'
option 'encryption' 'none'

Network Configuration

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth1'
option type 'bridge'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.xxx.xxx'
option dns '8.8.8.8'

config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'

config switch
option name 'switch0'
option reset '1'

config interface 'mnet'
option proto 'static'
option ipaddr '10.xxx.xxx.xxx'
option netmask '255.0.0.0'

Install Wifi Supplicant

opkg update
opkg install wpad

OLSR Configuration

root@OpenWrt:~# cat /etc/config/olsrd 

config olsrd
option IpVersion '4'
option FIBMetric 'flat'
option LinkQualityLevel '2'
option LinkQualityAlgorithm 'etx_ff'
option OlsrPort '698'
option Willingness '3'
option NatThreshold '1.0'
option MainIp '10.xxx.xxx.xxx'

config LoadPlugin
option library 'olsrd_arprefresh.so.0.1'

config LoadPlugin
option library 'olsrd_dyn_gw.so.0.5'

config LoadPlugin
option library 'olsrd_httpinfo.so.0.1'
option port '1978'
list Net '0.0.0.0 0.0.0.0'

config LoadPlugin
option library 'olsrd_nameservice.so.0.3'

config LoadPlugin
option library 'olsrd_txtinfo.so.0.1'
option accept '0.0.0.0'

config Interface
option ignore '0'
option interface 'mnet'
option Mode 'mesh'

config InterfaceDefaults
option Mode 'mesh'

Share and Enjoy

  • Facebook
  • Twitter
  • Delicious
  • LinkedIn
  • StumbleUpon
  • Add to favorites
  • Email
  • RSS

Comments are closed.