Connecting a Draytek 3100 to Cisco 1814/877 over SHDSL…

Connecting a Draytek 3100 to either a Cisco 877 or 1814

Draytek:

Draytek 3100 SHDSL to Cisco 1814 2Draytek 3100 SHDSL to Cisco 1814 3 Draytek 3100 SHDSL to Cisco 1814 1
Cisco

interface ATM0/1/0
 no ip address
 no snmp trap link-status
 no atm ilmi-keepalive
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface ATM0/1/0.1 point-to-point
 ip address 192.168.1.1 255.255.255.252
 no snmp trap link-status
 pvc 2/100
  oam-pvc 0
  encapsulation aal5mux ip
 !
!

Share and Enjoy

  • Facebook
  • Twitter
  • Delicious
  • LinkedIn
  • StumbleUpon
  • Add to favorites
  • Email
  • RSS
Posted in How To Guides, Personal Projects | Tagged , , , , , | Leave a comment

Hatteras Network HN-408-CPi BT EFM/SHDSL

Overview and Description (Commonly Used by BT EFM)

Hatteras Network HN-408-CPi 02Hatteras Network HN-408-CPi 03Hatteras Network HN-408-CPi 01Hatteras Network HN-408-CPi 04

Share and Enjoy

  • Facebook
  • Twitter
  • Delicious
  • LinkedIn
  • StumbleUpon
  • Add to favorites
  • Email
  • RSS
Posted in Little Guides | Tagged , , , , , | Leave a comment

Cisco CLI Commands… reference guide…

Below I list a CLI Command reference for Cisco routers.

# Configure Interfaces

interface FastEthernet0/0
description SOMEDESCRIPTION
ip address 192.168.1.1 255.255.255.0
no ip proxy-arp
duplex auto
speed auto

OR

interface FastEthernet0
 description Local LAN1
!
interface FastEthernet1
 description Local LAN1
!
interface FastEthernet2
 description Local LAN1
!
interface FastEthernet3
 description Local LAN1
!
interface Vlan1
 description Local LAN
 ip address 192.168.1.1 255.255.255.0

# Configure DHCP

ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool pool1
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
option 66 ascii "http://provisioning.domain.local/yeslink.php"

# Configure default routes

ip route 192.168.1.0 255.255.255.0 10.0.0.25

route of last resort resort

ip route 0.0.0.0 0.0.0.0 10.0.0.96

# Configure NAT to access the internet

interface vlan1
 description LAN
 ip address 10.10.11.1 255.255.255.0
 ip nat inside
 ip virtualreassembly in
!
!
ip access-list extended NAT
 permit ip 10.10.11.0 0.0.0.255 any
 remark access list for NAT
 ip nat inside source list NAT interface Dialer1 overload
!

# Configuring a sample NAT (Network Address Translation) Rule

# Configuring a sample PAT (Port Address Translation) Rule

object network WebServer-HTTP
host 192.168.102.5
nat (inside,outside) static 192.168.1.194 service tcp 80 80

# Configure TelNET

Setting up an access list

ip access-list standard telnet-in
permit 192.168.1.0 0.0.0.255
deny any

Setting up the ports

line vty 0
 session-timeout 30
 access-class telnet-in in
 password password
 login
 transport input all

# Configure system user environments

hostname ROUTERNAME
username test privledge 15 password 0 password

# Configure Vlans

interface Vlan1
 description LAN
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 description VOICE
 ip address 192.168.2.1 255.255.255.0
!
interface Vlan3
 description CCTV
 ip address 192.168.3.1 255.255.255.0
interface FastEthernet0
switch port access vlan 1
 description Local LAN
!
interface FastEthernet1
switch port access vlan 2
 description Local Voice
!
interface FastEthernet2
switch port access vlan 3
 description Local CCTV
!
interface FastEthernet3
switch port access vlan 1
 description Local LAN
!

# Configure FTTC / VDSL

how to configure a Cisco 887 router for VDSL vlan 101 (based on a BT Infinity service – UK)

VDSL Interface and subinterface

interface Ethernet0
no ip address
interface Ethernet0.101
encapsulation dot1Q 101
pppoe enable
pppoe-client dial-pool-number 1

Shut down the ATM interface and subinterfaces

interface ATM0
shutdown

Create the Dialer1 interface

interface Dialer1
description Dialer interface for VDSL
mtu 1492
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow ingress
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
ppp authentication pap chap ms-chap callin
ppp chap hostname xxxx
ppp chap password xxxx
ppp ipcp address accept
no cdp enable

# Configure Controller DSL 0

controller DSL 0
 mode atm
 line-term cpe
 line-mode 2-wire line-zero
 dsl-mode shdsl symmetric annex B
 line-rate auto
!
interface ATM0
 no ip address
 ip broadcast-address 0.0.0.0
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip broadcast-address 0.0.0.0
 snmp trap link-status
 pvc 0/38
  encapsulation aal5mux ppp Virtual-Template1
 !
!
interface ATM0.2 point-to-point
 ip broadcast-address 0.0.0.0
 snmp trap link-status
 pvc 0/21
  oam-pvc manage cc segment direction sink
 !
!
interface Virtual-Template1
 bandwidth 2000
 ip address negotiated
 keepalive 1
 ppp chap hostname USERNAME
 ppp chap password 0 PASSWORD
 ppp pap sent-username USERNAME password 0 PASSWORD
 ppp ipcp route default
 service-policy output parent
 hold-queue 224 in
!

# Configure Configure ATM0/0/0

interface ATM0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip address 192.168.1.6 255.255.255.252
 pvc 2/100 
  no oam-pvc manage
  encapsulation aal5mux ip
 !
!

# Configure Dual xDSL connection (ATM 0/0/0 & ATM 0/1/0)

interface ATM0/0/0
no ip address
ip broadcast-address 0.0.0.0
shutdown
no atm ilmi-keepalive
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex B
dsl linerate AUTO
!
interface ATM0/0/0.1 point-to-point
ip broadcast-address 0.0.0.0
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface ATM0/0/0.2 point-to-point
ip broadcast-address 0.0.0.0
pvc 0/21
oam-pvc manage cc segment direction sink
!
!
interface ATM0/1/0
no ip address
ip broadcast-address 0.0.0.0
shutdown
no atm ilmi-keepalive
dsl equipment-type CPE
dsl operating-mode GSHDSL symmetric annex B
dsl linerate AUTO
!
interface ATM0/1/0.1 point-to-point
ip broadcast-address 0.0.0.0
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface ATM0/1/0.2 point-to-point
ip broadcast-address 0.0.0.0
pvc 0/21
oam-pvc manage cc segment direction sink
!
!
interface Dialer0
description ADSL Connection to Internet
ip address negotiated
encapsulation ppp
load-interval 30
dialer pool 1
dialer-group 1
keepalive 1
no cdp enable
ppp chap hostname USERNAME
ppp chap password 0 PASSWORD
ppp pap sent-username USERNAME password 0 PASSWORD
ppp multilink
ppp multilink links maximum 2
ppp multilink links minimum 2
ppp timeout retry 1

# Simple VRF config

ip vrf TABLE1
ip vrf TABLE2

interfaces fa0/0
ip vrf forwarding TABLE1
ip address 1.1.1.1 255.255.255.0

interfaces fa0/0
ip vrf forwarding TABLE2
ip address 2.2.2.2 255.255.255.0

Show ip vrf status

show ip vrf

Using VRF in OSPF

router ospf 1 vrf TABLE1
network 1.1.1.1 0.0.0.0 area 0

router ospf 2 vrf TABLE2
network 2.2.2.2 0.0.0.0 area 0

seeing global routes

show ip route

Seeing routes in table1

show ip route vrf TABLE1

Seeing routes in table2

show ip route vrf TABLE2

# Rip Configuration

router rip
network 10.0.0.0
network 192.168.1.1
no auto-summary

# OSPF Configuration

router ospf 1
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
!

# BGP Configuration

router bgp 65501
 neighbor 10.10.10.2 
 remote-as 2000
 password 
 ebgp-multihop 2
 update-source loopback0
 address-family ipv4 unicast 
  route-policy xxxxx in 
 !
!
!
router static
 address-family ipv4 unicast
 10.10.10.2/32 TenGigE0/1
 commit
!

# Connect two Cisco Routers together with G.SHDSL Point-Point
ROUTER 1 : Cisco 1841

interface ATM0/0/0
 ip address 192.168.1.1 255.255.255.252
 no atm ilmi-keepalive
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface ATM0/0/0.1 point-to-point
 no snmp trap link-status
 pvc 2/100 
  oam-pvc 0
  encapsulation aal5mux ip
 !
!
interface ATM0/1/0
 ip address 192.168.1.5 255.255.255.252
 no atm ilmi-keepalive
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface ATM0/1/0.1 point-to-point
 no snmp trap link-status
 pvc 2/100 
  oam-pvc 0
  encapsulation aal5mux ip
 !
!

Router 2 : Cisco 877

controller DSL 0
 mode atm
 line-term cpe
 line-mode auto enhanced
 dsl-mode shdsl symmetric annex A
interface ATM0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
 ip address 192.168.1.6 255.255.255.252
 pvc 2/100 
  no oam-pvc manage
  encapsulation aal5mux ip

# Factory Reset Vyatta

erase nvram: all

Share and Enjoy

  • Facebook
  • Twitter
  • Delicious
  • LinkedIn
  • StumbleUpon
  • Add to favorites
  • Email
  • RSS
Posted in How To Guides | Tagged , , , , , , , , , , , , , , | Leave a comment

The RAD LA-210 EFM SHDSL Box

Overview and description (Commonly Used By TalkTalk Business EFM)

When you order an EFM connection you are sent an RAD EtherAccess LA-210 unit to be installed on your premises. This is referred to as the Network Termination Equipment (NTE) or occasionally the RAD box.rad efm 3

The purpose of the NTE is to ‘bond’ the multiple lines that are used on an EFM connection into one line. There are Ethernet ports on the rear of the NTE that allow you to plug your own equipment (such as a router) in.

It’s important to realise that the LA-210 is not a router, and it is up to you to either configure your network to use the EFM connection, or purchase the optional router.

Because this RAD Box bonds 2 wire telephone lines (up to a total of 4 lines or 8 wires) together the effect is that you get an Eithernet cable/network cable that you can then plug in to your own kit

Some providers then have there own routers like Cisco, ZyXEL, and junipers connected to this box and can offer a whole range of services like VoIP, Data, CCTV etc.

Some providers also route your traffic directly in to there data centers, creating a private connection between you and the data center. This is usful for centrally managing internet connections and access, or to enable you to have a central hosted VoIP PBX in the cloud and connect all your phones to it.

Rear of the LA-210

The LA-210 provides four RJ-45 ethernet ports that the you can plug your own equipment into. These are on the far right of the picture below.

The two RJ-45 ports to the left are intended to accept the bonded copper lines. You should not need to touch these, and no other equipment should be plugged in here.

LA210_rear

Front of the LA-210

The front of the LA-210 includes LED lights that can indicate the state of the unit and the connection.

Please note when reading the table below that the indicated status of the WAN light will vary depending on whether your EFM circuit is a two-pair or four-pair installation.

LA210_front

LED/Name

Function

TXT (Yellow)

On: A test is active
Off: A test is inactive

ALM (RED)

On: A new alarm is detected in the alarm buffer
Off: No alarm currently detected

WAN (SHDSL SYNC – green/red/orange)

Blinking (green/red): At least one line is synchronized and at
least one line is trying to synchronize.
On (orange): At least one line is synchronized. All other lines
are unsynchronized and are not trying to synchronize.
On (green): All lines are synchronized
Blinking (red): No lines are synchronized. At least one line is
trying to synchronize.
On (red): No lines are synchronized

LAN (LINK/ACT – green)

On (green): Ethernet link is up
Off: Ethernet link is down

E1

On (green): E1 link is up
Off: E1 link is down

RTS

On (green): RTS has been received
Off: RTS has not been received or serial port is
administratively disabled

FUN Stuff – Accessing the Config

FOLLOW THE BELOW AT YOUR OWN RISK!!! – I TAKE NO RESPONSIBILITY!!
THE BELOW IS FOR INFORMATIONAL EDUCATIONAL PURPOSES ONLY!!

Now that we know what the RAD box is and does. Lets see if we can have some fun with it.

If you have had an EFM service installed by TTB then, you should be able to access the config on the RAD box. You simply need a USB to Serial adaptor.

Open Hyper terminal or putty and use the rate of 9600 on your com port, open the connection, then press enter a few times. you should see a prompt like the below:

 Loading ...
Decompressing to RAM.

Processing archive: FLASH
Extracting LA_210.BIN ................................................................................................................................................................................................... CRC OK
Running ...
*******************************************************************
* In order to start working - press the ENTER button for few times*




user>

Enter the user name “su” and password “1234

user>su
password>****


TEST#

if you type “info detail“, you will see the whole config of the RAD unit.

if you have a spare one or ha accuired it from someplease, then you can reconfigure it.

below i have listed a very simple config that you can copy and paste in to a factory reset unit.

to factory reset the box type “admin” <Prese enter> type “factory reset

this shows you the simple syntax the RAD box uses and configures it with some simple test stuff

 configure 
 router 1
 interface 1
 address 192.168.1.125/24
 management-access
 no shutdown
 exit
 default-gateway address 192.168.1.1
 exit

 management 
 manager 192.168.1.10
 exit
 user su password password
 user oper password password
 user tech password password
 user user password password
 exit

 system date-and-time
 sntp server 1 address 8.8.8.8
 zone gmt
 exit
 exit

 system
 name TEST
 contact "Bob The Builder"
 location "My Comms Room"
 exit

exit all
save
save

Share and Enjoy

  • Facebook
  • Twitter
  • Delicious
  • LinkedIn
  • StumbleUpon
  • Add to favorites
  • Email
  • RSS
Posted in How To Guides, Little Guides | Tagged , , , , , | Leave a comment

ZyXEL Point-to-Point Link

ZyXEL Point-to-Point Link

zyxel_782r_modem

Overview

By using two (now inexpensive) ZyXEL SDSL (Symmetric DSL) modems it is possible to set up an IP link between two locations with noting more than a single copper pair. I’ve used two ZyXEL Prestige 782R G.SHDSL Routers which can be obtained cheaply on places like Ebay. The link speed is symetrical 2.3 Mbps.

The first stage is to get at theserial console. I’ve used a no-name USB to serial adapter. The default settings of the dvice are 9600,8N1. Connect up the serial cable and get a console (I’ll not go into that here – if you need help with that then the rest of this how-to will be of little use (sorry). When you have a working console, turn the device on and you’ll see:Bootbase Version: V2.07 | 3/15/2002 14:29:16
RAM: Size = 8192 Kbytes
DRAM POST: Testing: 8192K OK
FLASH: Intel 8M *2ZyNOS Version: V2.50(BH.4) | 8/6/2002 10:56:21

Press any key to enter debug mode within 3 seconds.
……………………………………………………

After that you’ll see:

Copyright (c) 1994 – 2002 ZyXEL Communications Corp.
initialize ch =0, ethernet address: 00:a0:c5:c0:ff:ee
Wan Channel init ………… done
Press ENTER to continue…

At this point press enter to get a password prompt. If you have “aquired” the device then it’s likely the password will have been changed from the default “1234” (after all everyone changes the default password 😉 ). If the password fails then you need to upload a new default configuration file (sometimes called a ROM). I have mirrored it. You need to dowload 250BH4C0.rom. Your terminal software needs to be able to do XMODEM. To flash the modem firstly get to the debug console – press Enter as it boots:

Bootbase Version: V2.07 | 3/15/2002 14:29:16
RAM: Size = 8192 Kbytes
DRAM POST: Testing: 8192K OK
FLASH: Intel 8M *2

ZyNOS Version: V2.50(BH.4) | 8/6/2002 10:56:21

Press any key to enter debug mode within 3 seconds.
……….
Enter Debug Mode

 

Next get the modem ready for receiving the upload by typing ‘ATLC’:

ATLC
Starting XMODEM upload (CRC mode)….
CC

Next use your terminal client to upload the file in XMODEM mode (I have use Minicom):

Welcome to minicom 2.6.1

OPTIONS: I18n
Compiled on Feb 11 2012, 18:56:01.
Port /dev/ttyUSB0
+———–[xmodem upload – Press CTRL-C to quit]————+
Press CTR|Sending 250BH4.bin, 8693 blocks: Give your local XMODEM recei|
|ve command now. |
|Bytes Sent: 16384 BPS:874 |
Bootbase | |
RAM: Size|Transfer complete |
DRAM POST| |
FLASH: In| READY: press any key to continue… |
+————————————————————-+
ZyNOS Version: V2.50(BH.4) | 8/6/2002 10:56:21

Press any key to enter debug mode within 3 seconds.
……..
Enter Debug Mode
ATLC
Starting XMODEM upload (CRC mode)….
C
Total 16384 bytes received.

Erasing..
….
OK

As you have go this far you may as well upgrade to the latest v2.50(BH.4) if your not at it, by repeating the above but with the 250BH4.bin. This time use the ‘ATUR’ command.

At this point you should have two modems, running v2.50(BH.4).

Configuration

The next step is to configure the modems to act as a bridge.i Label the modems ‘local’ and ‘remote’. We’ll configure the ‘local’ modem first. Connect to the console, and enter the password ‘1234’ to get to the main menu:Copyright (c) 1994 – 2002 ZyXEL Communications Corp.

Prestige 782R Main Menu

Getting Started Advanced Management
1. General Setup 21. Filter Set Configuration
2. WAN Setup 22. SNMP Configuration
3. Ethernet Setup 23. System Password
4. Internet Access Setup 24. System Maintenance
25. IP Routing Policy Setup
Advanced Applications
11. Remote Node Setup
12. Static Routing Setup
15. SUA Server Setup 99. Exit

Enter Menu Selection Number:

 

Firstly, change the system name to ‘local’, feel free to fill in location and contact person. Disable ‘Route IP’ and ‘Route IPX’ and enable ‘Bridge’:

Menu 1 – General Setup

System Name= local
Location= Close to me
Contact Person’s Name= Andrew

Route IP= No
Route IPX= No
Bridge= Yes

Under menu 2, change ‘Service Type’ to ‘Server’ and ‘Transfer Max Rate(Kbps)’ to ‘2312K’ and ‘Transfer Min Rate(Kbps)’ to ‘136K’:

Menu 2 – WAN Setup

Service Type= Server
Rate Adaption= Enable
Transfer Max Rate(Kbps)= 2312K
Transfer Min Rate(Kbps)= 136K
Standard Mode= ETSI(ANNEX_B)

 

Under menu 3, choose menu 2. In this menu set ‘DHCP’ to ‘None’. Set ‘IP Address’ to ‘192.168.1.100’ (change this of course if you need to):

Menu 3.2 – TCP/IP and DHCP Ethernet Setup

DHCP Setup
DHCP= None
Client IP Pool Starting Address= N/A
Size of Client IP Pool= N/A
Primary DNS Server= N/A
Secondary DNS Server= N/A
Remote DHCP Server= N/A
TCP/IP Setup:
IP Address= 192.168.1.100
IP Subnet Mask= 255.255.255.0
RIP Direction= Both
Version= RIP-1
Multicast= None
IP Policies=
Edit IP Alias= No

 

Under menu 11, choose menu 1. Chnage ‘Route’ to ‘None’ and ‘Bridge’ to ‘Yes’. You can give it a better name than ‘ChangeMe’ if you wish:

Menu 11.1 – Remote Node Profile

Rem Node Name= ChangeMe Route= None
Active= Yes Bridge= Yes

Encapsulation= RFC 1483 Edit PPP Options= N/A
Multiplexing= LLC-based Rem IP Addr= N/A
Incoming: Edit IP/IPX/Bridge= No
Rem Login= N/A Edit ATM Options= No
Rem Password= N/A
Outgoing: Session Options:
My Login= N/A Edit Filter Sets= No
My Password= N/A PPPoE Idle Timeout(sec)= N/A
Authen= N/A PPPoE Service Name= N/A

That is all that is needed for the local modem. You can of course go into menu 23 and change the password 😉 For the remote, again connect up the serial console and get to the main menu. Again go into menu 1 and change the system name to ‘remote’, Disable ‘Route IP’ and ‘Route IPX’ ensure ‘Bridge’ is also set to No:

Menu 1 – General Setup

System Name= remote
Location= Far away from me
Contact Person’s Name= Andrew

Route IP= No
Route IPX= No
Bridge= No

Next in menu 2 ensure ‘Service Type’ is set to ‘Client’ and ‘Transfer Max Rate(Kbps)’ to ‘2312K’ and ‘Transfer Min Rate(Kbps)’ to ‘136K’:

Menu 2 – WAN Setup

Service Type= Client
Rate Adaption= Enable
Transfer Max Rate(Kbps)= 2312K
Transfer Min Rate(Kbps)= 136K
Standard Mode= ETSI(ANNEX_B)

 

Next in menu 3, choose menu 2, set ‘DHCP’ to ‘None’. Set ‘IP Address’ to ‘192.168.1.101’ (again change this of course if you need to):

Menu 3.2 – TCP/IP and DHCP Ethernet Setup

DHCP Setup
DHCP= None
Client IP Pool Starting Address= N/A
Size of Client IP Pool= N/A
Primary DNS Server= N/A
Secondary DNS Server= N/A
Remote DHCP Server= N/A
TCP/IP Setup:
IP Address= 192.168.1.101
IP Subnet Mask= 255.255.255.0
RIP Direction= Both
Version= RIP-1
Multicast= None
IP Policies=
Edit IP Alias= No

 

Finally, Under menu 11, choose menu 1. Chnage ‘Route’ to ‘None’ and ‘Bridge’ to ‘Yes’. You can give it a better name than ‘ChangeMe’ if you wish:

Menu 11.1 – Remote Node Profile

Rem Node Name= ChangeMe Route= None
Active= Yes Bridge= Yes

Encapsulation= RFC 1483 Edit PPP Options= N/A
Multiplexing= LLC-based Rem IP Addr= N/A
Incoming: Edit IP/IPX/Bridge= No
Rem Login= N/A Edit ATM Options= No
Rem Password= N/A

Outgoing: Session Options:
My Login= N/A Edit Filter Sets= No
My Password= N/A PPPoE Idle Timeout(sec)= N/A
Authen= N/A PPPoE Service Name= N/A

That should be it, connect a cable between the two xDSL sockets, power cycle both and wait for the xDSL lights to come on (~60 seconds). Connect the ‘local’ modems ‘Lan 10/100M’ socket to your network, the ‘remote’ modems LAN socket should now be just an extension of your network. Note:The IP address of both modems (192.168.1.100 and 192.168.1.101 in the example above) will not be pingable, but the modems will transparently transit traffic.

 

Credit : Andrew @ https://www.fermit.org.uk/quickies/zyxel_point_to_point_link.html

Connecting

Share and Enjoy

  • Facebook
  • Twitter
  • Delicious
  • LinkedIn
  • StumbleUpon
  • Add to favorites
  • Email
  • RSS
Posted in Recent Client Installs | Leave a comment